Ben NanoNote user questions

Jump to: navigation, search

post any questions or tech support requests for your Ben NanoNote here...

Wolfgang Spraul23:25, 30 March 2010

How to display Chinese character in NN ? Since i cannot find /usr/share/i18n, and openwrt seems don't have "locale". So I don't know how to setup. Could someone give me a direction? Thanks.

Evanc311:55, 31 March 2010

the gtk program already display chinese. search 'stardict' in wiki. or you can try to port the 'zhcon' to nanonote, if you want the display chinese in console. I ready start a little bit on 'zhcon' :-)

Xiangfu11:56, 10 June 2010
 

I´m trying to communicate the SD port with a FPGA which simulates a SD card. What i want to do is to send a data by the SD port, any idea how to do that?

Luisklg19:27, 3 April 2010
 

I'm hard of hearing in noisy environments, so my application idea is a "smart hearing aid/music player/noise canceling ear phones", ie. I want to be running the thing continuously, with the lid closed, in my pocket, with (at least two channel preferably more) microphone input and two channel audio out.

1) Can it run with the lid closed? 2) How long will the battery last on one charge?

Thanks!

202.37.96.3523:31, 15 April 2010

> 1) Can it run with the lid closed?

Yes.

> 2) How long will the battery last on one charge?

I have measured about 5 and a half hour runtime with the display turned on and the cpu decoding ogg vorbis audio files. You can expect it to run some more hours when you turn off the display backlight (which you won't need anyway when you close the lid).

Wejp06:36, 17 April 2010
 

With only cron running (I was testing maximal battery time) it was running from 1 am to 6 pm, more or less. Around 15 hours, but without processing anything or the like, also the screen was off (it auto turns off after a while) and the lid closed.

Ruben

[[User:RBerenguel|RBerenguel]15:52, 8 May 2010
 

Hey, what is the entry for the micro sd card in /etc/fstab? thanx for help Hans

Hans06:14, 27 April 2010

OpenWrt use UCI system, please checkout: http://wiki.openwrt.org/doc/uci http://wiki.openwrt.org/doc/uci/fstab

xiangfu

Xiangfu08:45, 27 April 2010
 

A few things. One. Would this thing be useful to make a robot with?

these questions are all related to each other, I guess, so I'll make them one big question. Can I get a graphical text editor (gedit) running on this thing without much complaint? Also, could I run a webkit based browser (like midori), or would that kill the system's limited RAM? And can I connect USB Wifi adapters to the nanonote, like an old Linksys b/g antenna (http://www.vdhsoft.be/memo/19495.HTM for reference purposes)? It works flawlessly under other Linux distributions, but I was thinking about using that in conjunction with my Ben, to connect in a few places and get online, partly to show off, partly to have fun with it. Also, does the gmenu based GUI lend itself easily to running more than one program at once (e.g a small IM client, like Finch, and Dillo/midori/lynx), or will I mostly be running one program at a time? If it doesn't run well, how well does this system work with the byobu (Screen's more mature cousin) system?

That was a long one. I have two more, one's a technical, the other one is sort of random. So, on the technical side. It says something about shorting two wires for updating the Ben. How do I go about doing that? I'm pretty new to electronics, but in my experience, shorting wires usually leads to shocking the crap out of myself. If someone would like to post a tutorial, I'd be pretty happy with that, since I have no idea what I should do there.

Finally, in all the images of gmenu2x, I see that big dock on the top, and that little bar on the bottom. Is there any way I could reverse those, so I could have the big dock on the bottom and the little one on top, like a little GNOME desktop? It's sort of a silly question, but I wasn't sure.

199.217.0.6113:43, 20 May 2010
 

How can I emulate this software? Ideally I'd like to emulate this using virtual box with the correct screen resolution.

Also What programming language would you suggest I use to write for this device (specifically at this screen resolution)

Thanks!

Asdf0911:49, 10 June 2010
 

Hi, i am new to the nanonote, worked fine for a bit but now won't boot up beyond the open wrt splash screen... goes blank after printing -i2s mapping ok. any help?

River22618:00, 23 September 2010

River226,

Does the screen stay blank after pressing a key?

Did you flash your image or install any software before you started seeing this problem?

Before the problem occurred, had you set up your NanoNote to connect over USB? I'm particularly curious if you can still ping or ssh into the device.

Alan Post09:12, 24 September 2010

I have been playing with it, but i have not flashed it yet, and i can't remember if i have tried usb boot before or after this problem, but i know i tried it around the time of it.... but i have not tried to ping it yet, because i get a blank, and stays that way even after i press keys.

River22620:42, 24 September 2010

I have seen this before in cases where our NAND/ECC handling got confused by flipped bits and stopped booting. Fortunately several NAND and ECC related bugs have been fixed in recent months, so I would first try to just reflash your NanoNote to the latest software. Or try booting from a microSD card, and when you are at it you can try Jlime too.

Wolfgang Spraul07:10, 26 September 2010
 
 
 

Hi, I recently re-flashed the software in my nanonote and now it wont switch on, I cant even try to reflash again as I cant get it into USB boot mode and lsusb doesnt find it. No error messages on screen, I have tried charging the battery, the screen does not light up and stays blank and it doesnt appear to be powering up. Any suggestions?

Gunni11:08, 16 March 2011

the "unbrick guide" did the trick, spot of solder got her up and running again!

Gunni13:03, 2 April 2011
 

I've been searching for a long time for a device that is low on EMF emission (low-frequency electromagnetic radiation). Netbooks have about the same EMF emission as notebooks, but e-books have almost no EMF emission, even e-books like the Iliad which don't have a processor that turns itself off. Since the NanoNote has a low voltage battery (lithium 3V instead of 15V in netbooks/notebooks) and the MIPS processor it uses was originally meant for e-books, this could be the ideal device. Could someone tell me what the EMF emission for the Ben NanoNote is? Thanks in advance.

Nesterna09:04, 17 May 2011
 

Hi, I have a new Ben Nano Note and I am having problems getting it to switch on. It never seems to respond to the power on button, but can be made (sometimes) to switch on by removing battery/connecting USB lead etc. I have not been able to get it to power on today at all.

I tried the reflashing procedure, which worked, and the device powered on. After shutting down, it reverted to not powering on very often. Could this be a defective unit?

Thanks,

Grunthus16:58, 26 May 2011

Update: Pressing the recessed reset switch on the back of the base of the Ben, seems reasonably reliable in getting it to start.

Grunthus18:30, 26 May 2011

Update2: Still problems "powering on" today. A little progress however: when it did power up yesterday I set up ssh access with password via USB cable. Now tonight, when I try to power it up, nothing visible happens, however the Ben does respond to ping and I can ssh in over USB, just the display is not powering up for some reason.

Grunthus18:09, 27 May 2011
 
 
 
Personal tools
Namespaces
Variants
Actions
Navigation
interactive
Toolbox