Talk:Ethernet over USB

From Qi-Hardware
Jump to: navigation, search
Start a new discussion

Contents

Thread titleRepliesLast modified
Minor changes102:44, 25 December 2011
Preferred distro to connect to nanonote?102:41, 25 December 2011

Minor changes

[edit] Changes to ben-net.sh

On my system which runs Trisquel (based on Ubuntu) I had to make the following changes to ben-net.sh:

Change:

  if (/usr/bin/lsusb -t -d "0525:a4a1"); then

to

  if ( /usr/bin/lsusb -t -d "0525:a4a1" ); then

Changed:

  if !( /usr/sbin/iptables -L | grep $GATEWAY_IF ); then

to

  if !( /sbin/iptables -L -t nat -v | grep $GATEWAY_IF ); then

The first change was mostly cosmetic but may cause problems on some shells that require spacing.

The second change was necessary. Without it the script kept adding rules to the nat table as the nat table is not listed with just the -L option, also without the -v option the interface is not shown, and so we have the same problem of multiple rules being added. It should also be noted that even on a system where the -L option alone listed both the nat table and showed the interface you'd probably want to add the -n option to speed things up by avoiding the DNS look-ups.

Also if you are cutting and pasting from the web site use an editor with highlighting. I had to retype two of the "if" statements to get then to be parsed correctly. (must be some odd/hidden characters or something)

Hope this helps anyone having difficulties. Much thanks to the original poster. Saved me much time.

Freemor15:59, 11 August 2011

@Freemor thanks. wiki page updated. BTW: en.qi-hardware.com enable the anonymous edit.

Xiangfu02:44, 25 December 2011
 

Preferred distro to connect to nanonote?

When I first got my nanonote, the ethernet over USB worked fine with Ubuntu/Linux Mint by following the instructions given. However, after an upgrade I found this would no longer work... hoped it would be fixed in the next release and gave up on the idea once I realised it wasn't. I was tinkering with some old hardware the other day and following a similar method trying to get my ancient machine online over a serial connection and again the forwarding didn't seem to be working. So my question is: What distro are you guys using? Anyone had similar trouble with Ubuntu/Ubuntu-based distros and fixed it?

Thanks in advance...

Gunni10:30, 2 December 2011

@Gunni I am sure I tested the Ethernet Over Usb in every release. I am using the latest release 2011-11-23. if you have more question about this please send email to http://lists.en.qi-hardware.com/mailman/listinfo/discussion or here: IRC #qi-hardware on freenode

Xiangfu02:41, 25 December 2011
 
Personal tools
Namespaces
Variants
Actions
Navigation
interactive
Toolbox
Print/export